Minimum System Requirements

Operating System:

Operating system: Windows 7, Mac OS X 10.7, Ubuntu 12.04, Debian 7, openSUSE 13.1, or Fedora Linux 21

Software:

Adobe Acrobat Reader to print certificates (download)

Browser:

Firefox, Google Chrome, Microsoft Internet Explorer 11 or Edge, Safari 9

Equipment:

5Mbps Broadband internet connection. Click here to test your internet connection speed.